Web Client dependencies

The following scripts and style sheets are required for running the Web Client version 4 on your own site. Add these to the header of the page that embeds the Web Client.
<head>
   <meta name="viewport" content="width=device-width,height=device-height,initial-scale=1.0"/>
   <link rel="stylesheet" href="https://webchat-converse.converse.pitneycloud.com/css/converse-chat.css">
   <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.5.0/css/all.css" integrity="<hash>" 
        crossorigin="anonymous" />
   <link rel="stylesheet" type="text/css" href="https://cdn.jsdelivr.net/npm/slick-carousel@1.8.1/slick/slick.css"/>
   <script src="https://code.jquery.com/jquery-3.3.1.min.js"></script>
   <script type="text/javascript" src="https://cdn.jsdelivr.net/npm/slick-carousel@1.8.1/slick/slick.min.js"></script>
   <script src="https://cdnjs.cloudflare.com/ajax/libs/socket.io/2.1.0/socket.io.js"></script>
   <script src="https://webchat-converse.converse.pitneycloud.com/js/converse-chat.js"></script>
</head>

For a full example: in Designer: click Config and then go to the Integration tab.

Note: The Converse Web Client runs only in browsers that support TLS 1.1 or higher. This is not a problem for most users. The exception is Internet Explorer 10 and earlier where TLS 1.1 is not enabled by default (although users can configure this in Internet Explorer options).

When embedding the Web Client on a website, consider providing feedback to users when TLS 1.1 is not enabled.