Web Client dependencies (version 2 deprecated)

Note: Version 3 is now available. We recommend that you use version 3 for all new Web Clients, and that you upgrade any existing implementations to this version as soon as possible.

The following scripts and style sheets are required for running version 2 on your own site.

Page header

Add these style sheets to the <head> tag of the web page:

  • https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css
  • https://designer.converse.pitneybowes.com/public/slick/slick.css
  • https://designer.converse.pitneybowes.com/converseChatV2.css

For example:

<head>
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css">
    <link rel="stylesheet" type="text/css" href="https://designer.converse.pitneybowes.com/public/slick/slick.css" />
    <link rel="stylesheet" href="https://designer.converse.pitneybowes.com/converseChatV2.css" />
</head>

Page body

Add these scripts to the <body> tag of the web page:

  • https://code.jquery.com/jquery-latest.js
  • https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js
  • https://cdnjs.cloudflare.com/ajax/libs/socket.io/2.0.3/socket.io.js
  • https://designer.converse.pitneybowes.com/converseChatV2.js

For example:

<body>
    <script src="https://code.jquery.com/jquery-latest.js"></script>
    <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/socket.io/2.0.3/socket.io.js"></script>
    <script src="https://designer.converse.pitneybowes.com/converseChatV2.js"></script>

For a full example, see Web Client code example (version 2 deprecated).